Fantasy Worlds: Rhynn Mandatory Update to V. 1.3.7

Rhynn

Update 29-Mar-2012: this game no longer works. The servers have been shut down, perhaps permanently. 

Rhynn was updated to version 1.3.7 yesterday.  This is a mandatory update.  The Rhynn server was also updated and older versions will no longer work.  There are no new features in this version.

To Update Rhynn (iDen users): Press the “Send To Phone” button below to send Rhynn 1.3.7 to your Boost iDEN or Nextel phone. Then highlight Bolt in the Java Apps menu, press the “Menu” soft key and choose “Update“. Choose to “Keep existing data” when prompted and you won’t lose your settings.

Rhynn is another MORPG (Multi Player Online Game). This version is the latest “Demo” version of the game, released 19-Jul-2009. The game’s web site refers to  a full commercial version to be released “in 2006”. As far as I can tell the full version does not exist.  This game seems to be a demo only in that the game’s authors consider it incomplete. There do not appear to be any limitations to the game play and it is free. The game is be pretty responsive and playable on my i776 although it seems prone to getting server disconnection errors which require restarting the game! I’m hoping the server problems are temporary as this looks like it could be a great game

Type: Freeware

Vendor: AwareDreams- Product Page

Data Connection Required: Yes

Supported iDEN phones: All Falcon Series (i776, i9, i290, etc.) except the i465.

Downloading uses paid data. Downloads are for Java ME phones only.

To download and install click here: DOWNLOAD (jad)

Alternate downloads: jar zip

57 comments on this post.

  1. brandon says:

    Loads just fine but when i click connect it says error connection failure. Y does it do that. My connections just fine

  2. josh says:

    down loads just fine but it comes up with a message cannot connect too server try again later

  3. A.Master says:

    Hi all what is the xroads or crossroads i googled it and i cudnt find any thing about plz till me how to find. Oh and im A.M+EGY/CP LV. 95 AND 92 AND 75 ITS V GUD GAME !WINK!

  4. TommyBlaze says:

    907 Invalid JAR
    Error!: control flow verification information too large: a And that’s all it said. Might brick the thing even if it does install – they likely use some “non-standard” libraries for graphics/interface. RIM uses J2ME, but added/modified some internal code, causing backward compatibility to be minimal, if at all.

  5. TommyBlaze says:

    Is there some way to run this on a blackberry curve 8530?

Follow BoostApps on: